1982 Yamaha 650 Seca XJ650RJ - idle dies

Message
Author
alexp
Tricycle Squid
Tricycle Squid
Posts: 1
Joined: Mon Oct 24, 2011 1:44 pm
Sex: Male
Years Riding: 40
My Motorcycle: Yamaha XJ650J Maxim

1982 Yamaha 650 Seca XJ650RJ - idle dies

#1 Unread post by alexp » Sat Jul 27, 2019 2:19 pm

1. Engine completely rebuilt a few years ago - running fine
2. Full tank
3. New AGM batttery
4. Start engine - runs fine - drive 1 mile and stop for 30 min.
5. Get back on bike. Engine restarts fine.
6. Idle for a minute with petcock on Fuel
7. Suddenly - engine starts to die, as if there is no gas.
8. Crank engine - won't restart
9. Set petcock to Prime and crank again.
10. Eventually engine restarts.
11. Idle with petcock on Prime for a minute.
12. Engine again dies as if there is no fuel.
13. Restart engine with petcock still on Prime.
14. Engine restarts eventually.
15. Move Petcock back to 'Fuel and ride bike a few miles - runs fine.

What's going on ?? Has never happened before.

Thanks.

brajon
Veteran
Veteran
Posts: 51
Joined: Wed Apr 23, 2014 9:08 am
Real Name: Johnny
Sex: Male
Years Riding: 3
My Motorcycle: Honda

Re: 1982 Yamaha 650 Seca XJ650RJ - idle dies

#2 Unread post by brajon » Wed Dec 18, 2019 9:06 pm

Check the intake boots if there's any crack.

User avatar
ZooTech
Legendary 3000
Legendary 3000
Posts: 3137
Joined: Mon Jun 13, 2005 9:23 am
Sex: Male
Years Riding: 17
My Motorcycle: 2009 Kawasaki Nomad
Location: Ohio

Re: 1982 Yamaha 650 Seca XJ650RJ - idle dies

#3 Unread post by ZooTech » Sun Dec 22, 2019 3:00 pm

Could be a lot of things but I suspect a failed vacuum diaphragm in your petcock, or the hose that provides it, or sticky floats.

pchast
Site Supporter - Silver
Site Supporter - Silver
Posts: 498
Joined: Tue Sep 02, 2008 7:04 pm
Real Name: Pete
Sex: Male
Years Riding: 9
My Motorcycle: 1980 Suzuki GS550L, 2019 Zero DSR
Location: Athens, NY

Re: 1982 Yamaha 650 Seca XJ650RJ - idle dies

#4 Unread post by pchast » Sun Dec 22, 2019 10:35 pm

I had to pull my fuel valve and clean the vacuum chamber of dirt.
2019 Zero DSR, 1980 Suzuki GS550L

User avatar
totalmotorcycle
Administrator
Administrator
Posts: 29352
Joined: Sat Nov 22, 2003 7:00 pm
Real Name: Mike
Sex: Male
Years Riding: 28
My Motorcycle: 2013 Moto Guzzi V7 Stone
Location: Waterloo, Ontario
Contact:

Re: 1982 Yamaha 650 Seca XJ650RJ - idle dies

#5 Unread post by totalmotorcycle » Mon Dec 23, 2019 7:53 am

I had the exact same bike and mine did something like that for a month till I figured it out. With mine it was the left rear turn bulb causing a short, the bulb was rusty on the end of it, once I replaced it, all fine. So I'd recommend checking all your bulbs. Yes, odd suggestion, but it worked for me.

Also, check both ends of your battery ground as well.

Mike
NEW 2020 Motorcycle Model Guides
2019 Motorcycle Model Guides

Total Motorcycle is official Media/Press for Aprilia, Benelli, Beta, Bimota, BMW, Brammo, Buell, Can-Am, CCW, Ducati, EBR, Harley-Davidson, Honda, Husqvarna, Husaberg, Hyosung, Indian, Kawasaki, KTM, KYMCO, Moto Guzzi, Moto Morini, MV Agusta, Norton, Phantom, Piaggio, Polaris, Ridley, Roehr, Royal Enfield, Suzuki, Triumph, Ural, Vespa, Victory, Yamaha and Zero.

User avatar
NorthernPete
Site Supporter - Gold
Site Supporter - Gold
Posts: 3430
Joined: Mon May 02, 2005 10:24 pm
Real Name: Pete
Sex: Male
Years Riding: 11
My Motorcycle: 1988 Kawasaki Vulcan 1500
Location: Northern Ontario, Canada
Contact:

Re: 1982 Yamaha 650 Seca XJ650RJ - idle dies

#6 Unread post by NorthernPete » Mon Dec 23, 2019 9:01 am

Side note on this thread: welcome back zootech! Been what? 12 years? Lol
1988 VN1500

User avatar
ZooTech
Legendary 3000
Legendary 3000
Posts: 3137
Joined: Mon Jun 13, 2005 9:23 am
Sex: Male
Years Riding: 17
My Motorcycle: 2009 Kawasaki Nomad
Location: Ohio

Re: 1982 Yamaha 650 Seca XJ650RJ - idle dies

#7 Unread post by ZooTech » Mon Dec 23, 2019 2:09 pm

NorthernPete wrote:
Mon Dec 23, 2019 9:01 am
Side note on this thread: welcome back zootech! Been what? 12 years? Lol
Yes, I believe that's about right! Was quite surprised to find my username still worked after all this time...

Post Reply